High Sierraでgitが使えなくなったら

MacをHigh Sierraにアップグレードしたところ、gitが使えなくなってしまった

$ git xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

Developerツールを再インストールさせなければならないらしい。

unity$ xcode-select --install
xcode-select: note: install requested for command line developer tools

確認ダイアログが出るのでOKを押せば、インストールが始まる。インストールを完了すると、これまで通り、gitが使える様になる。

Via! https://e-yota.com/idle_talk/mac-os-high-sierra_git_xcrun_error/

Please follow and like us: